header image
Nieuws

Naast een veilige verbinding via HTTPS, is CADToppers.com nu ook beter te bekijken op mobiele platforms!

Topic: Defpoints.....  (gelezen 1748 keer)

Defpoints.....
« Gepost op: 22 oktober 2015, 15:52:40 »
Beste CADToppers,

Ik heb weer eens een bijzonder probleem.
We hebben een tekening van derde ontvangen, in deze tekening zitten 2 lagen, laag 0 en laag Defpoints.
Ook is er een Layer Filter Property aanwezig die GANTER heet.
Deze LFP bevat wel diverse lagen en zover ik kan zien, zijn deze allemaal unlocked.

Alles wat in de model space staat is echter gelocked.

Als ik elementen selecteer en ik kijk in de quickproperties, dan zie ik niet op welke laag het element zich bevindt. (Ik maak wat printscreens, ik kan helaas niet de tekening met jullie delen)
Als ik mijn muisaanwijzer boven een element hou, dan zie ik wel op welke laag het zich bevindt (GANTER_LOCKED)

Ik heb dus het idee, dat de LFP op een of andere manier op de laag DEFPOINTS terecht is gekomen.

Nu is de simpele vraag, hoe krijg ik deze elementen en/of laag UNLOCKED ?????? (Saveas DXF R12 maakt niks uit.)




[verwijderd door de beheerder, omdat deze bestanden al meer dan 50 dagen niet zijn gedownload]
Re: Defpoints.....
« Reactie #1 Gepost op: 22 oktober 2015, 16:21:08 »
Ik probeer dan een tekening te openen in MicroStation.
Beschik je over een ander tekenprogramma? probeer het dan daar eens mee.


Anders zou je het met vba of lisp kunnen proberen om alles op bv laag "0" te krijgen.


Trouwens al eens de "CLASSICLAYER" gebruikt? kijk eens of daarmee ook dezelfde dingen gebeuren.
Re: Defpoints.....
« Reactie #2 Gepost op: 23 oktober 2015, 09:59:05 »
Het is gelukt, ik zal kort toelichten hoe ik het probleem heb opgelost.

Na de opmerking van Eddy, heb ik de tekening geopend in pCon planner.
Alle elementen geselecteerd en een groep van gemaakt.
Daarna opgeslagen en geopend in AutoCAD
Dan een Block Edit op de <current drawing>
Het block op een willekeurige laag gezet. (Weet niet zeker of dit nodig was, maar je probeert wat)
Vervolgens het block geƫxplodeerd.
Daarna alles geselecteerd en naar een willekeurige laag verplaatst.
Block Edit afgesloten, alle elementen zijn nu weer gewoon te selecteren.
Tis een klus, maar gelukkig is ie geklaard  ;D ;D

P.s. Eddy, classiclayer maakt geen verschil.
Re: Defpoints.....
« Reactie #3 Gepost op: 3 november 2015, 08:20:28 »
De definitie in het filter blijft bestaan ook als er geen lagen met die naam in de tekening voorkomen.
(je kan een filter ook gewoon verwijderen zonder dat er wat met de tekening gebeurd)

Als er iets niet goed werkt probeer dan eerst recover of audit
Meestal zit het probleem in de database

Re: Defpoints.....
« Reactie #4 Gepost op: 3 november 2015, 08:54:54 »
Hoewel het blijkbaar is opgelost,was ik nog even aan het denken wat het nog meer kan zijn dat je de layers niet ziet...
Misschien staat er een vinkje aan bij 'Invert filter' terwijl een filter actief is, zie afbeelding.
Ik heb 30 layers, maar 2 worden afgebeeld...



Wil overigens niet zeggen dat die bij jou aan de hand was.

[verwijderd door de beheerder, omdat deze bestanden al meer dan 50 dagen niet zijn gedownload]
Re: Defpoints.....
« Reactie #5 Gepost op: 3 november 2015, 09:14:08 »
Bart en Eddy,

Audit en Recover maakt niks uit.
Invert filter staat niet aan.

Wat ook nog een probleempje is, is dat als je een element aanklikt, je niet kunt zien op welke laag het zich bevindt.
Zie printscreen.



[verwijderd door de beheerder, omdat deze bestanden al meer dan 50 dagen niet zijn gedownload]
Re: Defpoints.....
« Reactie #6 Gepost op: 3 november 2015, 11:00:48 »
Beste Richard de lagen zijn er niet!
In de layerfilter zie je ook geen lagen wat je ziet is de definitie van het filter
Als je een nieuwe laag aanmaakt die aan de definite voldoet bijvoorbeeld Stone1  (voldoet aan Stone*)
zal je zien dat er onder de filterdefinitie een extra tabel verschijnt met lagen die aan het filter voldoen.


als audite en recover niet werken ik weet bijna zeker dat de oorzaak van jouw probleem een proxy is.
Probeer superpurge eens om te kijken of er iets in de tekening zit
Re: Defpoints.....
« Reactie #7 Gepost op: 3 november 2015, 13:38:44 »
Ik ben met SuperPurge bezig om de tekening te purgen, alleen loopt SP vast.
Het bestand is 24MB groot, dat maakt het ook lastig om snel even wat dingen uit te proberen.

Omdat het inmiddels teveel tijd kost en ik het probleem al via een omweg heb opgelost, stop ik even met het testen van diverse dingen.

Hopelijk was dit de eerste en tevens laatste keer dat ik zo'n tekening binnen kreeg.

Iedereen bedankt voor het meedenken!!!!
Re: Defpoints.....
« Reactie #8 Gepost op: 4 november 2015, 08:23:45 »
Ik hoop het ook...
SuperPurge werkt niet echt heel snel.
Laatst gebruikte ik het ook en dacht dat acad was vast gelopen.
Maar heb een tweede programmavenster geopend en kon verder werken... In het eerste venster kon Spurge gewoon verder gaan... duurde beste een paar minuten (veel meer dan 5 min).
Maar na lang wachten (of lekker verder werken in ander venster) had ik toch iets...

Re: Defpoints.....
« Reactie #9 Gepost op: 4 november 2015, 08:35:34 »
Bij mij stond SP al meer dan een half uur te stampen, toen was ik er klaar mee ;)